Questions tagged [maintainability]

Maintainability refers to the nature, methods, theory and art of maximizing the ease with which an asset may be sustained, modified or enhanced throughout the duration of its expected useful life.

297 questions
0
votes
1 answer

is addon domain right choice for country specific domain hosting?

In our website we want to launch country specific domains. so which one is preferred over another like add-on, parked domains or anything that i don't know. our requirements is quite simple we want to publish country specific domain but the…
hi0001234d
  • 109
  • 3
  • 12
0
votes
0 answers

Android, big listeners, and performance/maintainability

I have a pretty big listener interface for an Android chat app. I also have an adapter for the listener, with empty methods. Here it is: public static interface Listener { public void connectionStarted(Server server); public void…
user2499946
  • 651
  • 8
  • 26
0
votes
1 answer

XSLT XPath style guide / best practice / coding standard?

Does there exist an XSLT / XPath style guide / coding standard / best practice reference? In particular I'm maintaining a bunch of XSLT scripts which are demonstrably fragile and unmaintainable. eg. Adding a single level of nesting to the XML…
0
votes
1 answer

Javascript Code Structure

So I'm making this app about a prison and prisoners etc, and I'm using the Observer Pattern. Ideally I would like to have only 1 global variable named App, and I would like to use the provided Observer Pattern code (in the link above) as a helper…
0
votes
3 answers

Magic numbers for parameters or method overloading?

I need to implement an interface for a class in C++ where I need to ask for events occured related with two kinds of sets, let's say here persons and actions. I need to ask for person identifier and action identifier in all possible combinations…
chorch
  • 133
  • 1
  • 7
0
votes
2 answers

Conditional-compilation vs run-time checks for client-specific customization?

As a vendor, we need to ship applications to many clients, and sometimes we need to customize the application for a specific client, for example by enabling or disabling certain features, or setting appropriate defaults for that client. I've seen…
sashoalm
  • 63,456
  • 96
  • 348
  • 677
0
votes
1 answer

Which is more conventional function name between "ContainsElement" and "DoesContainElement"?

I'm writing a function to determine whether an element exists in a container. I don't know how to choose the function name between: bool ContainerType::ContainsElement(const ElementType& elem); and bool ContainerType::DoesContainElement(const…
xmllmx
  • 33,981
  • 13
  • 121
  • 269
0
votes
3 answers

Is there any more compact way of writing that statement?

I had to write a script that generates some fixture file with increasing fake MAC addresses. To do that, I decided to have some fun and try to make it as compact as I could. I ended up with: def mac_address(i): return ':'.join(['%02x'] * 6) %…
ereOn
  • 48,328
  • 33
  • 147
  • 228
0
votes
1 answer

Which is the best exception to use? Or: how to deal with a misconfigured Activity?

This is a bit of an academic question, but I'm curious to get your input. I have an Activity which is loosely parameterized by a type string. When creating the Activity, I will always pass in the proper type via Intent's putExtra(). But I only want…
QED
  • 9,439
  • 6
  • 46
  • 82
0
votes
3 answers

Is there any easy way to develop easily maintainable code where XML parameters must have the same name as class variables in C#?

Let's say that my code has a class defined as so: class test{ bool var; public test(){} } In my main function, I create an object of the sort, and set var to true. After that I parse some XML files that contain the following:
0
votes
2 answers

Better way to program in matrix style selections in plsql?

By matrix style, I mean having n variables, each with some number of inputs, and having to handle all possible values. The simplest case of this is multiple boolean values and having to handle every combination of true/false. This is easy if the…
Lawtonfogle
  • 934
  • 4
  • 16
  • 30
0
votes
1 answer

returning from multiple points in a function

This is more or less a readability, maintainability and/or best practice type question. I wanted to get the SO opinion on something. Is it bad practice to return from multiple points in a function? For example.
au_stan
  • 3,551
  • 2
  • 16
  • 24
0
votes
2 answers

jQuery - Improving code and eliminating repetition

I have a series of calls to various jQuery methods and I was just wondering if there was a way to clean this code up, turn it into a function that I pass the selectors into, or anything else that could make the the code more manageable/maintainable.…
noclist
  • 1,368
  • 1
  • 18
  • 46
0
votes
1 answer

Adjust colors in vimrc or rather in the color scheme itself

In my case I do use the solarized color scheme. Until now I used to override certain color properties in my vimrc. But the number of adjustments seems to grow over time. Especially I tend to adjust colors used for UI elements, e.g. line numbers,…
Saucier
  • 3,632
  • 1
  • 20
  • 40
0
votes
3 answers

CSS - styles for unused elements?

Should I include 'default' styles in my stylesheet for elements, that aren't even used on my page? For example, when I only use h1, h2, h3 and h4, do I really need to add styles for h5and h6? Or when I don't use tables on my webpage, do I need to…
Sven
  • 12,129
  • 25
  • 82
  • 140
1 2 3
19
20